viernes, 18 de mayo de 2018

Creo que he conseguido una versión ejecutable de la la versión 2.4 de gvSIG

Tras varios intentos espaciados a lo largo del tiempo, creo que he conseguido una versión de gvSIG 2.4 (Build 2850) que funciona. Por un lado hay que suprimir algunas librerías y, por otro, arreglar los permisos. La versión de la página oficial solo funciona con el usuario root, pero después de quitarle algunas librerías.
Ya me contáis.
Podéis escribir a las listas de gvSIG que leo habitualmente.

viernes, 27 de octubre de 2017

Boa notícia gvSIG 2.4 RC3 está trabalhando em High Sierra (compilação 2841)

Eureka! gvSIG 2.4 RC3 funciona quase ao primeiro
Esta versão, 2.4 RC3, trabalhou com a última versão do MacOS quase sem fazer nada.
Opção A:
1. Baixe 2.4 RC3,
2. Botão direito (= controle + clique)
3. Mostrar o conteúdo da embalagem


4. Clique duas vezes em qualquer um dos arquivos que aparecem em preto (gvSIG, gvSIG-desktop)




5. Se todo o acima é muito complicado, vá para 6
6. Baixe este iniciador
7. Coloque 2.4 RC3 e o iniciador na mesma pasta

8. Clique duas vezes no iniciador (gvSIG-2.4)

¡Eureka! gvSIG 2.4 RC3 funciona casi a la primera

Esta versión, 2.4 RC3, ha funcionado con la última versión de MacOS casi sin hacer nada.
Opción A:
1. Descargar 2.4 RC3,
2. Botón derecho (=control+click)
3. Show el contenido del paquete
4. Doble click en cualquiera de los ficheros que aparecen en negro (gvSIG, gvSIG-desktop)



5. Si todo lo anterior es demasiado complicado, vete a 6
6. Descarga este fichero
7. Pon 2.4 RC3 y el lanzador en la misma carpeta
8. Doble click en el lanzador (gvSIG-2.4)

Good News gvSIG 2.4 RC3 is working in High Sierra (build 2841)

This release, 2.4 RC3, is working almost out of the box in the last mac version. Not tested in previous ones.
Right click show package contents and Contents/MacOS will give you the opportunity of launching it by double clicking either gvSIG or gvSIG-desktop.


In case the above is too complicated for you, just download this file and put both the original one and this in the same folder. Doble click and you're ready to go.

miércoles, 2 de agosto de 2017

After some time gvSIG 2.3.1 is running in Sierra


There is a problem with another library, this time libc++.1.dylib but after getting rid of it, things seem to be working now.


My actual configuration as any other mac running Sierra has libc++.1.dylib in /usr/lib, so there is no need for it inside gvSIG.
I have prepared a double click application that will work if gvSIG-desktop-2.3.1-2501-final-darwin_macos_10.11-x86_64 is located in the Applications folder.
So step by step:
2. Drag it to the applications folder
2. Open a terminal (the application is in Utilities)
3. Key 'mv /Applications/gvSIG-desktop-2.3.1-2501-final-darwin_macos_10.11-x86_64.app/gvSIG/extensiones/org.gvsig.gdal.app.mainplugin/gdal/libc++.1.dylib /Applications/gvSIG-desktop-2.3.1-2501-final-darwin_macos_10.11-x86_64.app/gvSIG/extensiones/org.gvsig.gdal.app.mainplugin/gdal/libc++.1.dylib.old' without quotes.
5. Double click
6. Enjoy
Keep in mind that the trick only works if gvSIG is in the applications folder and is not renamed.



Después de algún tiempo gvSIG 2.3.1 se ejecuta en Sierra

Hay un problema con otra biblioteca, esta vez libc ++. 1.dylib pero después de deshacerse de ella, las cosas parecen estar funcionando.


Mi configuración actual, como la de cualquier otro Mac ejecutando Sierra creo, tiene libc ++. 1.dylib en / usr / lib, por lo que no hay necesidad de tener la misma librería dentro de gvSIG.
He preparado una aplicación de doble clic que funcionará si gvSIG-desktop-2.3.1-2501-final-darwin_macos_10.11-x86_64 se encuentra en la carpeta Aplicaciones.

Así que paso a paso:
1. Descargar gvsig 2.3.1 para mac
2. Arrástralo a la carpeta de aplicaciones
2. Abre un terminal (la aplicación está en Utilidades)
3.  Teclea 'mv /Applications/gvSIG-desktop-2.3.1-2501-final-darwin_macos_10.11-x86_64.app/gvSIG/extensiones/org.gvsig.gdal.app.mainplugin/gdal/libc++.1.dylib /Applications/gvSIG-desktop-2.3.1-2501-final-darwin_macos_10.11-x86_64.app/gvSIG/extensiones/org.gvsig.gdal.app.mainplugin/gdal/libc++.1.dylib.old', sin comillas.
4. Descarga la aplicación de doble clic
5. Haga doble clic

6. Disfruta

Todo esto funciona solo si no cambias el nombre de la aplicación y la pones en la carpeta de aplicaciones

viernes, 30 de septiembre de 2016

Great news!!!

gvSIG is back to Mac.

gvSIG Press announced early this morning that gvSIG2.3 has been released for mac.
First tests on Mavericks are satisfactory so far.
The package contains all things needed to run.
Load with 335 algorithms is ready to be used.

jueves, 4 de diciembre de 2014

gvSIG 1.12 en Yosemite

En las décimas jornadas de gvSIG nos han vuelto a prometer una versión para Mac. Entre tanto y dado que Yosemite compremete la usabilidad de gvSIG os adjunto una serie de trucos para hacer funcionar tanto gvSIG 1.12 como gvSIG CE Beta Edition.
Para que corra la versión anterior en Yosemite (MacOS 10.10.1)
Hay que instalar Java 1.6
http://support.apple.com/kb/DL1572
Da igual que salga un león, se trata de la versión Java 1.6 para Mac
También se puede instalar la 1.8 pero antes que la 1.6
/usr/libexec/java_home -v
Dice cual es la versión que estas corriendo
parece que no hay incompatibilidad porque si se quiere usar la 1.8 se puede usar
export JAVA_HOME=`/usr/libexec/java_home -v 1.8`
que apuntará a
/Library/Java/JavaVirtualMachines/jdk1.8.0_25.jdk/Contents/Home
mientras que gvSIG 1.12 busca la 1.6 en:
/System/Library/Frameworks/JavaVM.framework/Versions
Inspirado en
http://www.jayway.com/2014/01/15/how-to-switch-jdk-version-on-mac-os-x-maverick/
y
http://stackoverflow.com/questions/6588390/where-is-java-home-on-osx-yosemite-10-10-mavericks-10-9-mountain-lion-10